Gathering meta-data fails when loading projects - unexpected behavior

I have WADE installed on my local hardrive and when I try to load old projects, it just displays a message gathering data but never loads...

On the browser app it works fine, that is, it gathers meta data olf old projects. But I'm having little trouble on wade installed my machine.

Will this go away if I reinstall wade? If so hopefully there is some possiblity of keeping the old games.wade files intact after install and uninstall...

A little help would be highly appreciate. Thanks!

All 10 Comments

Hi Prajwal

I know that the standalone / offline editor has got some issues still, and I'm trying to get them fixed for the next release.

Saying that however, I have never seen this particular issue. Do you get any error messages in the console at the bottom? Can you start a new project, or are you just stuck on the start screen?

If you can get into the editor (e.g. with a new project) then there is something you can do, even though this is a horrible hack :) 

Run your project (any project), then from the inline console (below the preview window, where it says "Write code here..."), type:

top.wide._currentProject = 'Name of project you want to download';

and then type;

I would do this just in case, so you can have a safe backup copy of your files. Then you could try overwriting the wade files to see if that makes any difference.

In fact, if you succeed and could somehow send me the zip file (via Private Message as an attachment if it's not huge), then I could try to replicate the problem and work on a fix.

Hey Gio,

I can start a new project and they do not throw this message but my old projects do. I'm sharing a screenshot of the app's start screen so you can have a look.

The project "test" which I created today is accessible where as my old projects aren't. And if I open them the code, files and scene objects are missing. Only folders remain.


Have you tried my suggestion above? That is, opening "Test" and then trying to download the other projects from the console with those commands I posted above. That way we can see if the project files etc are actually there

So I ran the command you gave in app.js in project "test" and I entered 'pongoal' as the top.wide._currentProject.

It did prompt a download and a zip file was donwloaded. Unfortunately it does not have files, my code or scene objects. There is a .wade file though but no assets in any folder.


It sounds like the file system is somehow corrupted, but maybe you can still find your files with a bit of luck and patience.

What I mean is that it is possible that the database storing the file names is corrupted, but the files themselves could still be on your disk,

If you are on Windows, try opening a file explorer window and going to %appdata%\WADE Game Engine\File System

There is a folder in there that may contain your files - the name of the folder on my ststem is 001\p but could be different on yours, I'm not sure how Chromium decides the name. Anyway, there should (hopefully!) be your project files there, just with meaningless names such as 000, 001, 002 etc. Not ideal, but it could be a way of recovering any important files that you don't have a backup copy of.

Thanks for the reply Gio... So yes, on my windows system I do see a folder 000\p

It contains a .usage file and two folders 02 and Paths. May I know how I can recover game files from this folder?


First look in 02 to see if your files are there, also look at the size of your files to see if they could be your project files.

You should be able to open these files in Notepad++ (for example) and look at the contents.

I can see 5 files which when opened with brackets and it contained project "test" files. The index.html, app.js, wade.js, style.css and the scene file.


I'm sorry to say that it looks like your files just aren't pysically there - I'm not sure how, but somehow they must have been deleted / removed... This isn't something that the editor would do though - in fact the editor seems to think they are still there. Perhaps the result of some disk cleaning operation? I'm sorry I can't help you more to recover those files, I hope your backups aren't too old. Has it been long since your last Download/Source?

As a side note (though it doesn't help you in this case) there is a plan for better offline storage for version 4.2 - a file system error is always going to be outside of our control, but admittedly we could do more to be able to recover files when something goes wrong.

Thanks so much Gio for trying to help and it's alright as mostly I had written logic for front end of my multiplayer games and I still have the files even though it can't be accessed by the editor. And yes, that feature would be great if I could recover files or maybe the cloud editor and standalone editor could have same projects, just a thought. But thanks for all the help!

Post a reply
Add Attachment
Submit Reply
Login to Reply