Mode Setting 2d to webgl

After an automatic update a couple of weeks ago I began having a problem with webgl in WADE.  The problem that I had was that the graphics in WADE would only display in 2d.  There was not a difference when the mode setting was changed to webgl.  The solution was to run Chrome in Compatibility Mode for either Window 7 or Windows 8.  This solved the problem with WADE not displaying webgl correctly.  This seems to be an issue that involves very specific variables (AMD Radeon GPU, Windows 10 64 bit OS, Chrome Version 57.0.2987.110 - I am not sure which one is the culprit as my laptop is set to auto update.  I blame Microsoft, but it is just speculation.).  Just wanted to share in case anyone else had this problem.

All 3 Comments

Thanks for letting us know.

Yes it's unusual but it does happen that a particular combination of graphics card + drivers + OS + browser results in poor or no WebGL support.

When you set a layer render mode to webgl, WADE will try to use web gl unless it detects that it is not supported, or that there would be major performance problems with it. In that case, it falls back to canvas 2d rendering.

I had no idea that running Chrome in compatibility mode would fix it. That's very good to know.

Another thing you could try is updating your graphics card drivers to the very latest version. Sometimes that works.


Wow, I did not expect a reply.  Very nice.  Thank you.  I feel afirmed.  :-) 

I tried changing the graphics card drivers to an older version and to the latest version, but these changes did not fix my problem (initially I thought that the Microsoft driver update for the graphics card was the likely culprit).  I also tried the portable version and the most recent beta version of Chrome to no avail.  I did find posts on forums for Chrome and Microsoft that there were issues with webgl in the past; however, most seemed to be from a few years back.  It is also possible that the additional security/encryption/account settings from my university exasperated the variables identified in my previous post.  Regardless, everything is working now and compatibility mode is the only change that mitigated the issue.  

Thank you!

Also, I really like the changes in the latest version of WADE.  Good work!


Hi Athanasius

That's interesting. I'm on a similar setup to you
Windows 10 64bit Os
Chrome Version 57.0.2987.110 (64-bit)
Radeon 7950hd (getting old)

Web gl mode works just fine for me without any issues. Sounds like a very specific issue

Post a reply
Add Attachment
Submit Reply
Login to Reply