In future never ever write code where you access the variable of the object by at .x or .y or .matched. It should be returnX, returnY or returnMatched. Although that takes longer when you come to make changes it is easier, cleaner and quicker. You should change it back when you compile or package code. Then users never to see your code or mess around with it. Good abstractions make upgrading so easy.
Just saying cause I am trying to hack something at the moment and it should not be this difficult.