Sprites (and TextSprites) both have setVisible and isVisible methods, but SceneObjects only have the setVisible method. Granted, it just goes in and sets all the component sprites to visible or invisible, as a shorthand.
But for the sake of consistency, would it not make sense to add an isVisible method to SceneObjects? Maybe the function could take an optional parameter to check if only one component sprite of the sceneobject is visible versus if all component sprites are visible, where the default would be to check if at least one component sprite is visible.
IMHO, it is generally expected that any object with a property setter would have a respective getter for the same property.